Impress keeps crashing

Discuss the presentation application

Impress keeps crashing

Postby buschbarber » Fri Oct 17, 2014 9:09 pm

I have been using OpenOffice Writer. on my Windows 7 PC, for years. Today was the first time I needed to create a presentation using Impress. A friend of my needed to give a talk including 5 jpg images and 3 mp4 videos.

I created 8 slides, each of which had a Title and a minimal amount of Text. I then went back and Inserted either a picture or a video in each slide. Each time I tried to do this, Impress would abruptly close, without warning, at some point during the insertion of a picture or video. It was not always at the same point in the process. Recovery failed and I had to start all over. I finally gave up as I could not figure out what caused the crash.
Rich
OpenOffice 4.1.1 on Windows 7
buschbarber
 
Posts: 5
Joined: Fri Oct 17, 2014 4:45 pm

Re: Impress keeps crashing

Postby buschbarber » Fri Oct 17, 2014 9:47 pm

I just tried creating the presentation again. I created the first slide and inserted a jpg image. I created the second slide and tried to insert one of the mp4 videos. I might add that these videos were downloaded from Youtube in mp4 format. I received an error message, for two of the videos, indicating that they were an invalid format. I tried inserting the third video and got no error message. The speaker icon appeared in the slide. After about 30 sec, Impress crashed.

I am not sure why two of the videos were recognized by Impress as an invalid format. They were all downloaded in the same manner as mp4 files. They all play correctly in Windows Media Player.

I had also gone to Tools/Options/Memory and increased the values to 50 Mb and 10 Mb, per a recommendation in another thread.
Rich
OpenOffice 4.1.1 on Windows 7
buschbarber
 
Posts: 5
Joined: Fri Oct 17, 2014 4:45 pm

Re: Impress keeps crashing

Postby RoryOF » Fri Oct 17, 2014 10:03 pm

We normally recommend adjusting the memory value to 256 MB (the max currently allowable). I use Xubuntu and rather than fiddle with embedding videos in a presentation, I use a hyperlink to the video file, which causes the sytem videoplayer to play the video. A bit clunky, but I've always found it reliable.
Apache OpenOffice 4.1.7 on Xubuntu 18.04.4 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 30910
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Impress keeps crashing

Postby buschbarber » Sat Oct 18, 2014 6:52 am

What should the value be for Memory per Object?
Rich
OpenOffice 4.1.1 on Windows 7
buschbarber
 
Posts: 5
Joined: Fri Oct 17, 2014 4:45 pm

Re: Impress keeps crashing

Postby buschbarber » Sat Oct 18, 2014 8:08 am

I raised the Memory values to 256Mb and 50Mb. I converted the videos from mp4 to mpg. When I insert an mpg into a slide, a question mark icon appears instead of a speaker icon. When Impress crashes and I try to recover, I get the error message that $ (ARG1) is corrupt and recovery cannot be completed.

I started another presentation and found that even with one slide, that is text only, if I wait a couple of minutes, Impress will crash.
Rich
OpenOffice 4.1.1 on Windows 7
buschbarber
 
Posts: 5
Joined: Fri Oct 17, 2014 4:45 pm

Re: Impress keeps crashing

Postby buschbarber » Sun Oct 19, 2014 2:49 am

I booted into my Ubuntu 14.04 machine and launched Libre OpenOffice Impress. I was able to create the presentation using the JPG images and MP4 videos.

When I inserted the MP4 videos into their respective slides, I found that if I clicked on the Link to File box, a Question Mark would appear in the slide. If I did not check the Link to File box, the image of the MP4 video appeared.

If I click on Slide Show (F5). the presentation plays the images and videos.

If I save the presentation as an ODF file and then launch it again, the slides are all correct as they were saved. If I save the presentation as a Microsoft Powerpoint PPT file, all the MP4 videos appear as Question Marks in their respective slides and do not play.

I want the presentation to be able to be opened by someone who has MS Powerpoint. I do not know if MS Powerpoint can read ODF files.
Rich
OpenOffice 4.1.1 on Windows 7
buschbarber
 
Posts: 5
Joined: Fri Oct 17, 2014 4:45 pm

Re: Impress keeps crashing

Postby Paolo38 » Fri Oct 24, 2014 3:22 am

Hi all crashers. I too have an ongoing issue with Impress. During the presentation, when I get to about the 6th slide, I get a pop-up error message: "Office 4.1.1. Fatal Error SEH Exception ACCESS VIOLATION". I have to then recover the file, but the same error keeps occurring.
Any ideas? (I'm using Windows 8.1.)
Thanks in advance,
Paolo
OpenOffice 4.01 on Windows 8.1
Paolo38
 
Posts: 5
Joined: Sun Nov 03, 2013 2:28 am

Re: Impress keeps crashing

Postby southwellpeter » Fri Nov 07, 2014 2:33 pm

I've just up graded to 4.1.1 from 3.2. Impress used to work fine and now repeatedly crashes. I suspect a bug. Will someone resolve this please?
Open Office 4.1.1
Windows 7
southwellpeter
 
Posts: 2
Joined: Fri Nov 07, 2014 2:30 pm

Re: Impress keeps crashing

Postby acknak » Fri Nov 07, 2014 7:17 pm

The usual approach anytime OO suddenly starts acting strange is to get a fresh OO settings profile. This just means exiting OO, renaming (or removing) the folder where OO stores all its settings, then restarting OO--it will then create a new settings profile folder.

For details, see: [Tutorial] The OOo user profile
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Impress keeps crashing

Postby bobgarrett » Sat Mar 14, 2015 1:18 pm

Like others on this thread I have found Impress keeps crashing. I have tried both the latest release (4.1.1) and 4.1.0. I have tried importing presentation into a new one. I have tried compressing the file. However, it does crash with increasing frequency. My presentation was, at one stage, quite big (~30MB) but by making images into image links and compressing the file it is now only about 8MB.
Since this is for a presentation to a number of people I have now given up and will have to use Powerpoint, but hopefully someone will look at fixing this.
OpenOffice 4.1 on Windows 7
bobgarrett
 
Posts: 17
Joined: Sat Mar 14, 2015 1:10 pm

Re: Impress keeps crashing

Postby utahman » Sun Mar 15, 2015 4:08 am

I have the same problem with it crashing in the middle of a slide presentation, after ten slides. Will try the idea of expanding the memory to the max, as suggested. Any other ideas are most welcome. I'm new to Open Office; most disconcerting.
Open Office version 4.1.1
Operating System: Windows 8.1 with Bing
utahman
 
Posts: 2
Joined: Sun Mar 15, 2015 3:59 am

Re: Impress keeps crashing

Postby bobgarrett » Sun Mar 15, 2015 11:33 am

I tried recreating OO settings, twice. This made no difference.
I also tried increasing memory to 250MB. This made no difference.
These were tried on both 4.1.0. and 4.1.1.
OpenOffice 4.1 on Windows 7
bobgarrett
 
Posts: 17
Joined: Sat Mar 14, 2015 1:10 pm

Re: Impress keeps crashing

Postby acknak » Sun Mar 15, 2015 3:05 pm

Sorry, I'm not sure what else you might try.

As a workaround, I always export my presentations to pdf and carry that as a backup. Most pdf viewers can run full-screen as a slide show. You don't get any animations or transitions but it's better than nothing.

If you want to invest some time in debugging, the first thing to determine is whether the problem is specific to your system or to the presentation, or whether it's something in Impress. You can try the presentation on a different system, or upload it here (or to some file sharing site) and we can try it.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Impress keeps crashing

Postby utahman » Mon Mar 16, 2015 3:24 am

The idea of going to Tools, then Options, then expanding memory to 256 MB (plus expanding memory for each slide to 20 mb or so) worked for me. Now I can go through the whole slide presentation without it crashing. Thanks RoryOF! :D
Open Office version 4.1.1
Operating System: Windows 8.1 with Bing
utahman
 
Posts: 2
Joined: Sun Mar 15, 2015 3:59 am

Re: Impress keeps crashing

Postby oldguy_46ca » Wed Mar 18, 2015 4:10 am

southwellpeter wrote:I've just up graded to 4.1.1 from 3.2. Impress used to work fine and now repeatedly crashes. I suspect a bug. Will someone resolve this please?

I tried to open the same PowerPoint file in both my Windows 7 Open Office 4.1.1 and my Wary Puppy Linux 5.5 installation. The file imports and opens OK but crashes on both platforms almost immediately. It lasts long enough in Windows to do a Save As to try to save it odp format but it crashes with the progress bar about halfway into the save.
Open Office 4.1.1 on Windows 7 Professional (64 bit) and Wary Puppy Linux 5.5
oldguy_46ca
 
Posts: 2
Joined: Wed Mar 18, 2015 3:55 am

Re: Impress keeps crashing

Postby rodgersoc01 » Mon Mar 23, 2015 8:43 pm

I am having the same problem with impress. I found sometimes that certain pics from internet cause it to crash. Also when I have 60 or more slides and I scroll through several slides using my scroller on mouse too fast it crashes. When I try to export impress presentation to pdf with several slides maybe 100 slides it crashes. My memory is set on high. There is an obvious glitch with impress. It is kind of annoying. I have been an impress user for years and I don't remember the previous versions crashing so much. It has been crashing on both windows 7 and 8 (OpenOffice 4.1.1). Please stop the crashing I don't want to go back to PowerPoint!
OpenOffice 4.1.1 on Windows 8
rodgersoc01
 
Posts: 2
Joined: Mon Mar 23, 2015 8:35 pm

Re: Impress keeps crashing

Postby thomasjk » Mon Mar 23, 2015 9:18 pm

rodgersoc01:
Did you use Tools-->Options-->Openoffice-->Memory to adjust your settings as mentioned above by utahman? Did the previous version also crash? If not you download and install it from http://www.openoffice.org/download/. Click the drop down box at the right for older versions.
Tom K.
Windows 10 Home version 1803 17134.165
LibreOffice 5.4.7.2
thomasjk
Volunteer
 
Posts: 4418
Joined: Tue Dec 25, 2007 4:52 pm
Location: North Carolina

Re: Impress keeps crashing

Postby RoryOF » Mon Mar 23, 2015 9:49 pm

When one has finished building a presentation, one should then minimise it (/Tools /Minimise presentation) this will leave the original untouched and make a copy, with graphics reduced to the optimum for the projector. This will cause the graphics to load very quickly and might solve your crashing problem..
Apache OpenOffice 4.1.7 on Xubuntu 18.04.4 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 30910
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Impress keeps crashing

Postby rodgersoc01 » Tue Mar 24, 2015 4:27 am

Thanks thomakjk for the details I did what you said so far so good. I did a test of scrolling through slides fast no crash, several times! In the past it crashed with no problem.
Hope this continues to work this way. Thanks again.
OpenOffice 4.1.1 on Windows 8
rodgersoc01
 
Posts: 2
Joined: Mon Mar 23, 2015 8:35 pm

Re: Impress keeps crashing

Postby Mr.Dandy » Wed Mar 25, 2015 3:40 pm

Paolo38 wrote:Fatal Error SEH Exception ACCESS VIOLATION

Read this: https://forum.openoffice.org/en/forum/v ... 10&t=72315
A ticket has been opened for this error.
OpenOffice 4.1.3 - Windows 7
User avatar
Mr.Dandy
 
Posts: 311
Joined: Tue Dec 11, 2012 4:22 pm

Re: Impress keeps crashing

Postby DS256 » Sat May 02, 2015 8:19 pm

FWIW, I ran into this problem today and increased my memory to 256 plus ran 'minimize presentation' and have not experience any crashes after frequent ones before.
OpenOffice 3.2 on Windows XP
DS256
 
Posts: 1
Joined: Wed Jul 28, 2010 3:56 pm

Re: Impress keeps crashing

Postby Steve5 » Wed Aug 05, 2015 7:16 pm

I'm trying to delete and add slides (the left column listing of slides) and every time I go to insert a slide the file crashes. Impossible to work with. I remember this happening a few months ago and I had to Ctrl-S every time I made a change to make sure it was saved with my most recent change. But I can't even get to that point because it crashes immediately.

Increase the memory, in Impress? Graphics cache?

I have an idea. I admit it's really radical, and I was hesitant to even bring it up. But I figured I'd throw it out there.
Instead of having to restart in Safe Mode, and look for some file somewhere, or increasing the memory, why don't they just fix this bug? Or is that asking too much?
OpenOffice 4.1.6, Libre Office 6.0.7.3, Windows 8.1 (All three have issues)
Steve5
 
Posts: 126
Joined: Sun Oct 20, 2013 4:23 am

Re: Impress keeps crashing

Postby RoryOF » Wed Aug 05, 2015 7:26 pm

If you started in Safe Mode and found what application was causing the interference, then there would be useful information to send to the developers. When OpenOffice is produced it is stable on the developers machines; such machine do not cover the entire range of software installed and installable on user's machines. Developers are dependant on informed feedback
Apache OpenOffice 4.1.7 on Xubuntu 18.04.4 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 30910
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Impress keeps crashing

Postby Steve5 » Wed Aug 05, 2015 7:45 pm

RoryOF wrote:If you started in Safe Mode and found what application was causing the interference, then there would be useful information to send to the developers. When OpenOffice is produced it is stable on the developers machines; such machine do not cover the entire range of software installed and installable on user's machines. Developers are dependant on informed feedback


How do I find what application is causing this? I'm not a techie and don't have a clue what you're talking about. But I thought that's what these boards are for -- identifying bugs, major bugs, and the powers that be, fix them. Silly me.

I might try restarting in Safe Mode, open up the file and see if I can work on it w/o it crashing.

I first brought up this issue in March, along with another wonderful bug that has gone ignored: https://forum.openoffice.org/en/forum/v ... 10&t=76269

Can I take an Impress slide show and transfer it to LibreOffice?
OpenOffice 4.1.6, Libre Office 6.0.7.3, Windows 8.1 (All three have issues)
Steve5
 
Posts: 126
Joined: Sun Oct 20, 2013 4:23 am

Re: Impress keeps crashing

Postby Steve5 » Wed Aug 05, 2015 9:46 pm

I downloaded LibreOffice and made the changes I wanted in five minutes. No Safe Mode, no looking for files, and no finding some application...no issues whatsoever. Go figure.

Also, LO doesn't have the extremely frustrating bug where if you're in one slide and want to go to another, and you click on it - surprise, surprise - it actually takes you to that slide you click on! Imagine that! Because in Impress, it takes you to the top slide instead and you have scroll down and find the slide you wanted to get into.
OpenOffice 4.1.6, Libre Office 6.0.7.3, Windows 8.1 (All three have issues)
Steve5
 
Posts: 126
Joined: Sun Oct 20, 2013 4:23 am

Re: Impress keeps crashing

Postby David Cook » Wed Sep 23, 2015 10:09 pm

I had this problem to day when Apache OO 4.1.1 always crashed at a certain slide with the "Fatal Error SEH Exception. Access violation" " error message and it wouldn't let me print out the handouts either, always crashing beyond 15/29 slides presumably at a certain slide (I managed to print out the first 12) It also extended to the .ppt file copy I made and ran within Microsoft Powerpoint Viewer

After a lot of searching round the net and discovering it was a problem met with by others I solved it by uninstalling 4.1.1 and installing 4.0.1

But Windows 7 Home Premium wouldn't let be uninstall 4.1.1 a problem I solved by downloading Advanced Uninstaller Pro which I would recommend.
Open Office 4.1.1 on Windows 7 Home Premium
David Cook
 
Posts: 2
Joined: Wed Sep 23, 2015 3:49 pm


Return to Impress

Who is online

Users browsing this forum: No registered users and 3 guests