Missing text on card

Discuss the presentation application

Missing text on card

Postby pedro » Fri Feb 05, 2021 2:00 am

I am trying to use Impress to create a greeting card. But I have problems printing the text. It looks good on Impress, but when I tried to print it to an HP printer, I kept missing some of it. Then I tried to print to PDF to see if the problem was with the printer... The problem still is there in the PDF, so I think it is a problem with OpenOffice.

I just installed OpenOffice 4.1.8 to see if it fixed the problem.

First image is view of Impress, Each line of text is a separate text box:
office_card1.jpg


The second image is from the PDF file that is produced. I do not know if this is related to the problem, but I rotated the text box and it was not exactly to perpendicular.
office_card1_pdf.jpg
Pedro
OpenOffice 4.1.8
Windows 10
User avatar
pedro
 
Posts: 10
Joined: Sat Jul 25, 2015 12:18 am

Re: missing text on card

Postby pedro » Fri Feb 05, 2021 2:13 am

fyi. I played with trying to make the text boxes more perpendicular (and also the picture), but it only moved the problem to the next text box to the right.
Pedro
OpenOffice 4.1.8
Windows 10
User avatar
pedro
 
Posts: 10
Joined: Sat Jul 25, 2015 12:18 am

Re: Missing text on card

Postby Hagar Delest » Fri Feb 05, 2021 8:40 am

Can you upload the file itself? Replace the pic by something else so that it's less than 128kiB.
Is the PDF/A option checked? It may lead to issues with transparency. It should not in this case but can't see anything else so far.
LibreOffice 7.0.5 on Xubuntu 21.04 and 7.0.5 portable on Windows 10
User avatar
Hagar Delest
Moderator
 
Posts: 29753
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Missing text on card

Postby RoryOF » Fri Feb 05, 2021 10:51 am

It looks as if the Hello World 1/2 text box has an extra line below it that lies on top of the Hello World 3 text box, the background of Hello World 1/2 not being transparent. You may also need to check the Arrange function to get your text boxes to stack correctly front to back.
A copy of the .odp file would help. The rotation of the textbox to exactly 90 or 270 degrees would get the text exactly vertical.
Apache OpenOffice 4.1.10 on Xubuntu 20.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 32562
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Missing text on card

Postby pedro » Fri Feb 05, 2021 10:45 pm

RoryOF wrote:the background of Hello World 1/2 not being transparent.

Please remind of how to get the background of the text box to not being transparent.
Pedro
OpenOffice 4.1.8
Windows 10
User avatar
pedro
 
Posts: 10
Joined: Sat Jul 25, 2015 12:18 am

Re: Missing text on card

Postby pedro » Fri Feb 05, 2021 10:49 pm

Hagar Delest wrote:Is the PDF/A option checked?

Can you elaborate? I could not find "PDF/A" option.
Pedro
OpenOffice 4.1.8
Windows 10
User avatar
pedro
 
Posts: 10
Joined: Sat Jul 25, 2015 12:18 am

Re: Missing text on card

Postby RoryOF » Fri Feb 05, 2021 11:12 pm

PDF/A option is in the /File /Export as PDF dialog
Apache OpenOffice 4.1.10 on Xubuntu 20.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 32562
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Missing text on card

Postby pedro » Fri Feb 05, 2021 11:33 pm

Hagar Delest wrote:Can you upload the file itself? Replace the pic by something else so that it's less than 128kiB.

I had various results:
1. picture A... text is messed up as described in original post.
2. replaced with smaller picture (call it B)... all of the text looks fine.
3. no picture at all... all of the text looks fine.
4. different picture (call it C), similar size as original... text is messed up.
5. picture C, but resized smaller within OpenOffice, but 1 inch away from text... all of the text looks fine
6. picture C, but resized smaller within OpenOffice, but adjacent to text... text is messed up.
7. picture B, but resized larger within OpenOffice, to similar size as picture A... all of the text looks fine.

Based on the results I see, I think the problem is with the pictures and not with the text.

I am unable to upload any files with pictures, but here is one without the picture (#3 above). Perhaps if you can add a picture to reproduce this problem.

card5.odp
(12.95 KiB) Downloaded 35 times
Pedro
OpenOffice 4.1.8
Windows 10
User avatar
pedro
 
Posts: 10
Joined: Sat Jul 25, 2015 12:18 am

Re: Missing text on card

Postby pedro » Fri Feb 05, 2021 11:38 pm

RoryOF wrote:PDF/A option is in the /File /Export as PDF dialog


My original problem was with actual printing on paper, so I was trying to reproduce by printing to PDF. In the print dialog, I have a choice of my HP printer or "Microsoft Print to PDF" and some others.

Export to PDF seems to work. I will then print from the PDF.

There is something messed up with the printing to a PDF from OpenOffice. It seems to work differently than the export.
Pedro
OpenOffice 4.1.8
Windows 10
User avatar
pedro
 
Posts: 10
Joined: Sat Jul 25, 2015 12:18 am


Return to Impress

Who is online

Users browsing this forum: No registered users and 7 guests